You are here:   Documentation > DotNetNuke Version > Installing > Installing/Upgrading on DotNetNuke 4
Register  |  Login

Note: If installing on DotNetNuke 5 use the directions at this link



  • Requires DotNetNuke 4.9 or higher, SQL 2005 or higher, and ASP.NET 3.5 installed on the server

  • You must download, install, place on a page in your DotNetNuke website, and run LinqPrep first. You can obtain it here:

  • This module will only work if you have the sql database user as "dbo" (database owner)


To Install

Log into your DotNetNuke site as the Host account.


From the Host menu, select Module Definitions


Select Install New Module


Use the Browse button to navigate to the ADefHelpDesk install file and click the Install New Module button


The module will install. Click the Return button


When the module is installed, navigate to a page in your DotNetNuke site and select ADefHelpDesk from the Module drop down and click the Add button


The module will display



Compilation Error


If you get a Compilation error after installing the module, you neglected to download, install, and run LinqPrep first.


To fix the problem, delete the files in the App_Code\ADefHelpDesk directory (do not delete the directory itself) and install and run LinqPrep.

After LinqPrep is installed and run, re-install ADefHelpDesk.